All times are UTC - 5 hours [ DST ]


Post new topic Reply to topic  [ 25 posts ] 
Go to page 1, 2  Next
Author Message
 Post subject: windows 7 and saving in-game settings
PostPosted: Sat Apr 24, 2010 3:32 pm 
Offline
User Rep: Unsung
 Profile

Joined: Sat Nov 28, 2009 9:02 pm
Posts: 32
Hi all,

I took a hiatus from the game, and while I was away I upgraded to Windows 7. Now, after reinstalling the client and razor, things are just acting strangely.

First, it won't save my screen size settings, whether I do it from Razor or from the in-game options, it's always a tiny box when I first log on. Also, the music is always playing when I first log on, no matter how many times I turn it off in options.

I have to believe it's the UAC in Win7, but even after I turned them completely off it's still giving me problems. Has anybody else experienced this or is it unique to my installation?

Thanks in advance for any help anybody can offer!

- Glarus


Top
 
These Support SecondAge
Links open a new window.
UOSA Donors & Subscribers do not receive these ads.

 Post subject: Re: windows 7 and saving in-game settings
PostPosted: Sun Apr 25, 2010 3:37 am 
Offline
User Rep: Unsung
 Profile

Joined: Tue Jun 16, 2009 11:09 am
Posts: 949
have not heard of anyone else with this problem, since the files are written to Users folder where it has proper access to do so..

if you take full ownership of the UO directory it should work out also.. right click on your UO dir in program files (x86 if you're 64bit) and find the security options, get the full access option for owner/creator/you/etc ..

_________________
Yew Bank Mall - UOAM v8.3/v9/UOSA Client Installer - UOSA @ SourceForge.net (Latest Versions Here) - Treasure Maps Offline


Top
 

 Post subject: Re: windows 7 and saving in-game settings
PostPosted: Sun Apr 25, 2010 3:49 am 
Offline
UOSA Donor!!
UOSA Donor!!
User avatar
User Rep: Good
Good
 Profile

Joined: Tue May 05, 2009 10:03 am
Posts: 2262
Location: out selling permits
I'm having issues with this myself; if you run the Razor shortcut as administrator it'll load/save all your files accordingly (temp workaround.)

Been messing with security permissions and ownership but I've yet to figure out how to get razor/uo to run as a user and load/save normal settings. I think it has to do with the new installer, as I didn't have this issue with the old installer on my other Win7 machines.

_________________
Image
"I consider most of you NPC's that inhabit the single player game that I am here to enjoy." - MatronDeWinter


Top
 

 Post subject: Re: windows 7 and saving in-game settings
PostPosted: Sun Apr 25, 2010 4:33 am 
Offline
UOSA Donor!!
UOSA Donor!!
User avatar
User Rep: Good
Good
 Profile

Joined: Tue May 05, 2009 10:03 am
Posts: 2262
Location: out selling permits
I did a reinstall: Right-click on the installer, change the compatibity to Windows XP SP 2 or 3, then reinstall (can be run as user or administrator, doesn't matter.) It'll bypass the permissions crap and install normally. Then just copy your Razor/Ultima Online settings from your old machine.

You'll get the compatibility warning whenever you first run razor, but it'll run like a normal uo install and save/load your old data. Still haven't figured out the permissions crap, would be a much easier fix to already installed machines. =/

_________________
Image
"I consider most of you NPC's that inhabit the single player game that I am here to enjoy." - MatronDeWinter


Top
 

 Post subject: Re: windows 7 and saving in-game settings
PostPosted: Sun Apr 25, 2010 5:08 am 
Offline
User Rep: Unsung
 Profile

Joined: Tue Jun 16, 2009 11:09 am
Posts: 949
I don't see how any problems could be related to the installer --- all it does is install (with elevated permission). Running programs is left up to the OS.

I don't have any problems running Razor not-as admin either, all the settings and such load properly, as well as my UO configurations..

but, I'm not a PC noob so I might just run and "own" my computer better than others... Microsoft and their funky permissions don't phase me. But also, I took full ownership of my UO directory so I don't know how that plays a part in things.. probably just makes my life easier.

_________________
Yew Bank Mall - UOAM v8.3/v9/UOSA Client Installer - UOSA @ SourceForge.net (Latest Versions Here) - Treasure Maps Offline


Top
 

 Post subject: Re: windows 7 and saving in-game settings
PostPosted: Sun Apr 25, 2010 9:53 am 
Offline
User Rep: Unsung
 Profile

Joined: Sat Nov 28, 2009 9:02 pm
Posts: 32
Thanks Hicha, I'll uninstall and try that. Hopefully it'll help!


Top
 

 Post subject: Re: windows 7 and saving in-game settings
PostPosted: Sun Apr 25, 2010 11:16 am 
Offline
UOSA Donor!!
UOSA Donor!!
User avatar
User Rep: Good
Good
 Profile

Joined: Tue May 05, 2009 10:03 am
Posts: 2262
Location: out selling permits
Dagon wrote:
I don't see how any problems could be related to the installer --- all it does is install (with elevated permission). Running programs is left up to the OS.

I don't have any problems running Razor not-as admin either, all the settings and such load properly, as well as my UO configurations..

but, I'm not a PC noob so I might just run and "own" my computer better than others... Microsoft and their funky permissions don't phase me. But also, I took full ownership of my UO directory so I don't know how that plays a part in things.. probably just makes my life easier.


I think thats the issue; installing it with elevated permissions might be requiring the user to run it with elevated permissions. Right after installing I didn't have access to the UO folder, and I couldn't write to the Razor folder (from an admin account.) Changing the permissions I was able to correct both, however if I don't run the client as admin, it loads a blank slate UO and Razor (even though the Desktop files are there.) Running as admin loads all my info, etc.

I spent an hour going through permissions, from changing them on the UO directory to modifying the entire drive and the only way I've figured out how to get it to run right is by either running Razor as admin, or changing the compatibility to Windows XP SP2.

_________________
Image
"I consider most of you NPC's that inhabit the single player game that I am here to enjoy." - MatronDeWinter


Top
 

 Post subject: Re: windows 7 and saving in-game settings
PostPosted: Sun Apr 25, 2010 12:17 pm 
Offline
User Rep: Unsung
 Profile

Joined: Tue Jun 16, 2009 11:09 am
Posts: 949
Still don't think the installer matters.. read here from NSIS documentation about the execution level..

Quote:
Specifies the requested execution level for Windows Vista and Windows 7. The value is embedded in the installer and uninstaller's XML manifest and tells Vista/7, and probably future versions of Windows, what privileges level the installer requires. user requests the a normal user's level with no administrative privileges. highest will request the highest execution level available for the current user and will cause Windows to prompt the user to verify privilege escalation. The prompt might request for the user's password. admin requests administrator level and will cause Windows to prompt the user as well. Specifying none, which is also the default, will keep the manifest empty and let Windows decide which execution level is required. Windows Vista/7 automatically identifies NSIS installers and decides administrator privileges are required. Because of this, none and admin have virtually the same effect.

It's recommended, at least by Microsoft, that every application will be marked with the required execution level. Unmarked installers are subject to compatibility mode. Workarounds of this mode include automatically moving any shortcuts created in the user's start menu to all users' start menu. Installers that need not install anything into system folders or write to the local machine registry (HKLM) should specify user execution level.


So Windows itself decides NSIS installers should be run as admin regardless, and the execution level only applies to the installer anyways. The installer does in fact write to HKLM (uninstall info, UO client info, etc) so it needs admin level.

Running programs still comes down to the OS, user permissions, file ownership, etc...

Don't blame me, blame Microsoft!

By default you can't even go into Program Files and delete the Ultima Online directory because you don't have permission to do so, even if you're on an admin account.. you've got to take ownership of the entire folder to delete it. Also by default the config files SHOULD BE written out to the Users folder where they SHOULD BE working properly regardless of execution level or ownership.. if they're not then it's some oddness on each individual computer because not many others have the same/similar problem..

_________________
Yew Bank Mall - UOAM v8.3/v9/UOSA Client Installer - UOSA @ SourceForge.net (Latest Versions Here) - Treasure Maps Offline


Top
 

 Post subject: Re: windows 7 and saving in-game settings
PostPosted: Sun Apr 25, 2010 12:54 pm 
Offline
User Rep: Unsung
 Profile

Joined: Sun Apr 25, 2010 11:52 am
Posts: 445
I'm using Windows Vista and I'm encountering the same issue. I haven't encountered this until today. Tried the compatibility and changing the permission levels methods to no avail.

[EDIT]
I installed the client that came with the boxed disc and patched it to around 5.0.9, am currently using Razor to connect and am successfully changing the options.

_________________
"In case I don't see ya: Good afternoon, good evening and good night."


Last edited by Blackbeard on Sun Apr 25, 2010 2:36 pm, edited 1 time in total.

Top
 

 Post subject: Re: windows 7 and saving in-game settings
PostPosted: Sun Apr 25, 2010 1:13 pm 
Offline
User Rep: Unsung
 Profile

Joined: Fri Apr 23, 2010 1:57 pm
Posts: 18
I have the same problem with my new windows7 laptop.

I just reinstalled with the installer compatibility changed to XP sp2 and it did not fix the problem.
Then tried messing with permissions and all, running razor as admin, etc.

Would someone who has fixed this problem mind giving me a step by step starting with installation??

I have reinstalled about 7 times the last 3 days, and i am going to cry if i have to log in again and turn off the goddamn footsteps and change screen size...


Top
 

 Post subject: Re: windows 7 and saving in-game settings
PostPosted: Sun Apr 25, 2010 7:31 pm 
Offline
User Rep: Unsung
 Profile

Joined: Tue Jun 16, 2009 11:09 am
Posts: 949
http://www.blogsdna.com/2173/add-take-o ... dows-7.htm

just take ownership of the entire UO folder

_________________
Yew Bank Mall - UOAM v8.3/v9/UOSA Client Installer - UOSA @ SourceForge.net (Latest Versions Here) - Treasure Maps Offline


Top
 

 Post subject: Re: windows 7 and saving in-game settings
PostPosted: Sun Apr 25, 2010 10:41 pm 
Offline
UOSA Donor!!
UOSA Donor!!
User avatar
User Rep: Good
Good
 Profile

Joined: Tue May 05, 2009 10:03 am
Posts: 2262
Location: out selling permits
Dagon wrote:
http://www.blogsdna.com/2173/add-take-ownership-option-in-right-click-context-menu-of-windows-7.htm

just take ownership of the entire UO folder


I've already done this, doesn't change anything. I think it might have to do with windows shadowing, still testing this to figure it out.

Is there a way you can post the UO files separately, without the installer? I'd like to have the regular install versus your custom one.

On a side note; I copied the full UO directory from my XP box to my W7 box, and it runs fine. Still dunno wtf is up with this.

_________________
Image
"I consider most of you NPC's that inhabit the single player game that I am here to enjoy." - MatronDeWinter


Top
 

 Post subject: Re: windows 7 and saving in-game settings
PostPosted: Mon Apr 26, 2010 10:25 am 
Offline
User Rep: Unsung
 Profile

Joined: Mon Apr 26, 2010 10:20 am
Posts: 1
An Corp
I am having this same problem with XP. I'm using an admin account so that isn't the problem.

Something interesting is that when I change the settings in game and log off they are saved correctly in the UO.cfg but when I play again they are screwed up. I changed uo.cfg to ro to see what happened and as soon as I double click my character to log in the game tries to write to my uo.cfg again and crashes.


Top
 

 Post subject: Re: windows 7 and saving in-game settings
PostPosted: Mon Apr 26, 2010 1:30 pm 
Offline
User Rep: Unsung
 Profile

Joined: Fri Apr 23, 2010 1:57 pm
Posts: 18
i finally ended up downloading uo gold client and patching up to 5.0.9.1

everything works ok now. not sure what it is about the installer from UOSA, and i don't really care.

stoked


Top
 

 Post subject: Re: windows 7 and saving in-game settings
PostPosted: Mon Apr 26, 2010 2:27 pm 
Offline
User Rep: Unsung
 Profile

Joined: Sat Nov 28, 2009 9:02 pm
Posts: 32
cryostallion wrote:
i finally ended up downloading uo gold client and patching up to 5.0.9.1

everything works ok now. not sure what it is about the installer from UOSA, and i don't really care.

stoked


where did you get the uo gold client?


Top
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 25 posts ]  Go to page 1, 2  Next

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: Google Adsense [Bot] and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Support Second Age: These links Open in a New Window

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group  
Extended by Karma MOD © 2007—2012 m157y