All times are UTC - 5 hours [ DST ]


Post new topic Reply to topic  [ 37 posts ] 
Go to page 1, 2, 3  Next
Author Message
 Post subject: Musics are random?
PostPosted: Sun Jun 27, 2010 4:14 pm 
Offline
User Rep: Unsung
 Profile

Joined: Sun Jun 27, 2010 3:59 pm
Posts: 3
Hi, I'm new here and I'm loving to play UO old style, but there's something bugging me about the musics.
I'm using the full instalation provided here at UOSA and it's the only version I've got installed on my system right now. When I open the client, it's not always my beloved stones2 playing, seems like it ramdonly choses a song between stones2, oldult02 and create1 as far as I've noticed.
Also, when I go into war mode, it only plays one combat music and then it goes back to playing random city music, even though I'm still in combat. It takes some feeling out of it, you know?
I don't know if this is one of those era accurate things, as I've never played on OSI, I always played on freeshards and back at that time the musics didn't go all crazy like this. Stones2 is my official UO music and it's not the same thing to look at the login screen without it.
Is there some way for me to fix, maybe editing some file for the music list or something like that?
Thanks a lot, this is looking like a great shard.


Last edited by Mateus on Sun Jun 27, 2010 6:10 pm, edited 1 time in total.

Top
 
These Support SecondAge
Links open a new window.
UOSA Donors & Subscribers do not receive these ads.

 Post subject: Re: Musics are random?
PostPosted: Sun Jun 27, 2010 5:04 pm 
Offline
wobble llama
wobble llama
User avatar
User Rep: Unsung
 Profile

Joined: Fri Dec 19, 2008 4:32 am
Posts: 512
Location: Ultima Universe
What client version are you using?

_________________
+ORC: If you give a man a crack he'll be hungry again tomorrow, but if you teach him how to crack, he'll never be hungry again.
chumbucket: I don't collect pixels.

Never trust the client. It's in the hands of the enemy : UO Demo internals @ JoinUO


Top
 

 Post subject: Re: Musics are random?
PostPosted: Sun Jun 27, 2010 6:08 pm 
Offline
User Rep: Unsung
 Profile

Joined: Sun Jun 27, 2010 3:59 pm
Posts: 3
Sorry, I forgot to say I'm using only the version provided here at UOSA and no other installs beyond this one.
I'll edit the first post to include this info.


Top
 

 Post subject: Re: Musics are random?
PostPosted: Sun Jun 27, 2010 7:30 pm 
Offline
User Rep: Unsung
 Profile

Joined: Tue Jun 16, 2009 11:09 am
Posts: 949
The only thing changed in the client was to prevent Vista/Win 7 crashes, the music played at certain times or whatever has not been changed.

_________________
Yew Bank Mall - UOAM v8.3/v9/UOSA Client Installer - UOSA @ SourceForge.net (Latest Versions Here) - Treasure Maps Offline


Top
 

 Post subject: Re: Musics are random?
PostPosted: Mon Jun 28, 2010 2:14 pm 
Offline
User Rep: Unsung
 Profile

Joined: Sun Jun 27, 2010 3:59 pm
Posts: 3
So any ideas as to why won't the musics play according to the situation?
Is it working fine for everyone else?


Top
 

 Post subject: Re: Musics are random?
PostPosted: Mon Jun 28, 2010 10:02 pm 
Offline
UOSA Donor!!
UOSA Donor!!
User avatar
User Rep: Unsung
 WWW  Profile

Joined: Mon Apr 27, 2009 5:51 pm
Posts: 1190
Location: Trinsic
I noticed this too back when I started playing here. It was really annoying. (Un)luckily for me, UO kept crashing thanks to Windows, so I had to disable music all together....so I really haven't thought about it since then.

_________________
Dolphins are NOT era accurate, and MUST be banned!
Sign my PETITION!


Top
 

 Post subject: Re: Musics are random?
PostPosted: Fri Jul 02, 2010 11:39 am 
Offline
User Rep: Unsung
 Profile

Joined: Sat Aug 09, 2008 8:58 am
Posts: 341
I noticed this awhile back...it seems the game begins to play the right track whenever music is initialized. Such as entering a new area, going into warmode, etc. But after a short amount of time, it goes to playing a random track.

So you'll go into a dungeon and hear the track intended for it (usually something darker, eerie) then after 30 secs or so it'll start playing the song for Britain.

Same with combat....you'll go into warmode and it'll begin to play the fast-paced dramatic music, but after a short amount of time (while still in combat mode) it'll just revert to playing a normal, calmer track.

Dunno, it initializes the right tracks, but the songs don't continue to play like they should.

_________________
- Elisud


Top
 

 Post subject: Re: Musics are random?
PostPosted: Fri Jul 02, 2010 3:36 pm 
Offline
User Rep: Unsung
 Profile

Joined: Tue Jun 16, 2009 11:09 am
Posts: 949
hmm. ill try to look into it. i dont use music so ive never noticed.

_________________
Yew Bank Mall - UOAM v8.3/v9/UOSA Client Installer - UOSA @ SourceForge.net (Latest Versions Here) - Treasure Maps Offline


Top
 

 Post subject: Re: Musics are random?
PostPosted: Sat Jul 03, 2010 10:29 am 
Offline
User Rep: Unsung
 Profile

Joined: Sun Aug 03, 2008 1:46 pm
Posts: 20
I'm also encountering a similar problem in that certain music just won't play. For instance, tavern music will NEVER trigger for me. Same thing goes for "Forest_A" and a few less noticeable wilderness music tracks.


Top
 

 Post subject: Re: Musics are random?
PostPosted: Sun Jul 04, 2010 10:49 pm 
Offline
UOSA Subscriber!
UOSA Subscriber!
User avatar
User Rep: Good
Good
 Profile

Joined: Mon Apr 20, 2009 10:47 pm
Posts: 4550
I was getting this also, using the UOSA client. Just completely random music, like Britain music playing while I'm in Hythloth. Sometimes it would actually function correctly, but for the most part completely random.

May have had something to do with multi clienting, though none of my characters ever went to Brit. I had sound turned off in all client except one (which was the main character I was playing). I used the same client a week earlier and had no problems when I wasn't multi clienting.

_________________
<green> grats pink and co. .... the 3 of you f---ing scrubs together can blow up a bard. IMPRESSIVE


Top
 

 Post subject: Re: Musics are random?
PostPosted: Mon Jul 05, 2010 12:04 am 
Offline
User Rep: Unsung
 Profile

Joined: Sun Aug 03, 2008 1:46 pm
Posts: 20
Well I've did a bit of testing and I believe that it has something to do with the fact that at some point the client stopped full MIDI support and switched to MP3s. You can still use the original MIDI files to an extent, but the client stopped recognizing the MIDI config file that told it when to play what song. I don't have the faintest idea how to get around this. Maybe someone that's savvy in this area can take a crack at it?


Top
 

 Post subject: Re: Musics are random?
PostPosted: Mon Jul 05, 2010 12:46 am 
Offline
User Rep: Unsung
 Profile

Joined: Tue Jun 16, 2009 11:09 am
Posts: 949
the midi files do not use a config file, they (the list) are built into the client.
midi crashes windows vista / 7 and that's why we changed it, but only the sound output device and midi->mp3 conversion was done along with telling the client to use the mp3s rather than the midis, so it doesnt really make any sense.

just for the hell of it try this client.. it undoes one of the patches we did.. see if you notice any difference..
https://sourceforge.net/projects/uoseco ... e/download

_________________
Yew Bank Mall - UOAM v8.3/v9/UOSA Client Installer - UOSA @ SourceForge.net (Latest Versions Here) - Treasure Maps Offline


Top
 

 Post subject: Re: Musics are random?
PostPosted: Mon Jul 05, 2010 2:23 am 
Offline
User Rep: Unsung
 Profile

Joined: Sun Aug 03, 2008 1:46 pm
Posts: 20
Sorry, I should have been more clear with my wording. I didn't mean to imply that this bug just started occurring for me and I also wasn't referring to the MIDI to MP3 switch that just occurred to fix the client crashing problem. I was referring to the point in which EA (or OSI or whoever owned UO at the time) switched to the new music, which also happened to be in MP3 format.

When that happened (I was still paying to play at that point) I was able to get some semblance of the old music by deleting the MP3s from the music directory and replacing them with the original MIDI files, minus a config file. It basically created exactly the same situation I'm experiencing now.

I wish I could find which version of UO that actually has the config file, but it is definitely after the Second Age expansion, because I just reinstalled from my original T2A disc and the config file is absent from that installation. However, I know 100% for certain there was a config file at some point along the way (I distinctly remember changing Britain's theme from 'Britain 1' to 'Britain 2'). Whether that's relevant or not, I'm not sure. I know as it stands, our installation has it built right into the client, sans config.

So at any rate, I reinstalled the updated 5.0.8.3 client from the site, and installed the file you linked to in your previous post. Unfortunately, it didn't seem to alleviate the situation, but I was afraid of that since I was experiencing this problem before as well.


Top
 

 Post subject: Re: Musics are random?
PostPosted: Mon Jul 05, 2010 4:33 am 
Offline
User Rep: Unsung
 Profile

Joined: Tue Jun 16, 2009 11:09 am
Posts: 949
i know the ML release has the mp3s and config file, and i'm almost certain that if you allowed a t2a install to patch up to the current 7+ version you get the mp3s as well.. but again, the config file only applies to the new music mp3s, not to the original midis, and the new music mp3s are not the same music as the midis. but i did make the new mp3 music an optional download for anyone who wanted it.. see the sourceforge page in my sig..

perhaps the new music was EA's way of circumventing the crashing problem, since they were definitely aware of it.. i've got no information on whether or not the same crashing problem applies to the new music though.. never tested it.

but what you're saying is that even when you were playing on the pay servers with their client you still had this problem? so its unlikely that its anything related to any changes to the music ive done..

_________________
Yew Bank Mall - UOAM v8.3/v9/UOSA Client Installer - UOSA @ SourceForge.net (Latest Versions Here) - Treasure Maps Offline


Top
 

 Post subject: Re: Musics are random?
PostPosted: Mon Jul 05, 2010 9:57 am 
Offline
User Rep: Unsung
 Profile

Joined: Sun Aug 03, 2008 1:46 pm
Posts: 20
That's correct, this has been happening for years (at least for me) but it didn't start until AFTER they made the switch to using the new (horrible) MP3 tracks. I would dump the old MIDI files in the music folder and then they would work, except you would get no tavern music and random dungeon music after the first play, which is identical to the current problem. I just never had the initiative or the knowledge to fix it myself. I assumed it was a product of the newer clients and figured that since the UOSA client was based on the older clients, I would no longer encounter the problem.

Again, I wasn't trying to imply that it's anything you've done to cause this. The music is just a very important part of the old school UO experience for me (and I think for others as well) so I was just hopeful that there might be something that could be done to fix it. I know there are other things on the docket that are more pressing than the music, though, so if it doesn't get fixed, no big deal. :)


Top
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 37 posts ]  Go to page 1, 2, 3  Next

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: Google Adsense [Bot] and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Support Second Age: These links Open in a New Window

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group  
Extended by Karma MOD © 2007—2012 m157y