All times are UTC - 5 hours [ DST ]


Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: 64 Bit Windows: Installing the 5.0.8.3 Patch
PostPosted: Fri Aug 07, 2009 11:26 pm 
Offline
User Rep: Unsung
 Profile

Joined: Fri Aug 07, 2009 11:12 pm
Posts: 1
My problem is trying to patch the client up to 5.0.8.3. I'll try to be as detailed about my processes as possible:

I extracted the "UO Client Installer.exe" file and ran "SETUP.EXE".

My UO: TSE setup process:
1. Click "Advanced".
2. Click "Install Ultima Online: The Second Age" push button.
3. Select the "Full (589 MB)" radio button and click "Next >".
4. Enter a directory with the corresponding drive and click "Next >". So far, these are the following directories I've tried:
  • E:\Program Files\Ultima Online\
  • E:\Program Files (x86)\Ultima Online\
  • C:\Program Files\Ultima Online\ (NOTE: My C drive is mainly a storage drive, but I gave this a shot anyway)
  • E:\Ultima Online\
5. Click "Yes" when the message box asks if I would like to create the directory.
(It proceeds to install flawlessly.)
6. Click "OK" to the Success message box.
7. Click "Finish".
8. Click "Cancel" when the "Installing Demo" message box comes up.
9. Click "Yes" when the "Are you sure you want to quit?" message box comes up.

Now comes the patch... I've tried this several times and every time the same thing happens. It freezes while it's patching the file "anim.mul".

Attachment:
freeze.JPG
freeze.JPG [ 20.63 KiB | Viewed 4703 times ]


All of the following attempts were done with a fresh install:
  • First time, I just ran "patch5.0.8.3.exe" from the directory. I let it wait for about an hour, and it still was stuck. So I closed it, and uninstalled, and reinstalled to try again.
  • Second time, I copied the file to the directory it was installed and tried it. Same thing.
  • Third time, I copied the patch file and removed the "UO Client Installer" directory prior to patching, since it had the client in it and the patcher would potentially be finding that directory first and trying to patch that. Tried it again, waited an hour and a half this time since I read on the locked installation post that it takes time.
  • I also tried setting the process affinity of the patch to CPU 0 only. Didn't help.
  • I tried closing the patcher, then re-running the patch (although the files would be corrupt, as I later read in the forums). It took 7 patch attempts for it to completely patch using this method. But, of course, when I tried to run the client using Razor, the client crashed and Visual Studio gave me a "Just-in-time" error.
  • I tried running "uopatch.exe" and patching it that way, but it refused to patch past 4.0.x.x (I forget).
  • Also tried running the client through Razor unpatched, and it ran the UO Auto Patcher but, again, it would never go past 4.0.x.x no matter how many times restarted the client. Tried this method again on a fresh install and it exceeded 5.0.8.3 on the first auto-update.

It seemed some people had similar problems in the forums but no actual solution was ever posted/detailed.
I've spent about 5 hours trying to figure out how to get this to work, but I'm very patient and have no trouble spending many more. =)

Oh. I'm using Windows XP Professional 64-bit, which I read should be working fine.

Any help on this matter would be greatly appreciated! :)

Thank you kindly,

Varkalas D`Lonovan


Top
 
These Support SecondAge
Links open a new window.
UOSA Donors & Subscribers do not receive these ads.

 Post subject: Re: Installing the 5.0.8.3 Patch
PostPosted: Sat Aug 08, 2009 3:53 am 
Offline
wobble llama
wobble llama
User avatar
User Rep: Unsung
 Profile

Joined: Fri Dec 19, 2008 4:32 am
Posts: 512
Location: Ultima Universe
Here's a solution that works but takes some techninal know-how:

1) Start the patcher. It will hang at "a" (random) file.
2) Keep the patcher open
3) Go your TEMP-directory, make sure your explorer is configured to show hidden files and directories
--- c:\Documents and Settings\<username>\Local Settings\Temp
4) There will be a directory _ir_vp2_temp_XXX
--- where XXX is number, most likely 0 or 1
5) That directory contains 2 JPG's and 1 VPATCH.EXE
6) Copy the "vpatch.exe" to your UO install directory
7) Close the failing patching process
8) That temp directory should get deleted but atleast you have the important vpatch.exe now
7) Create a shortcut to the "vpatch.exe"
8) Open the shortcut properties, we need to modify the command line and set Windows 98 mode
9) Append this parameter to the shortcut target:
Code:
"__IRAFN:D:\UO-Install\UO Client Installer\patch5.0.8.3.exe"
REPLACE THE PATH WITH YOUR INSTALLER PATH!!!
10) On the "Compatibility" tab configure Windows 98 (VERY IMPORTANT STEP)
11) Press OK to close the properties window
12) Double click the shortcut to start the modified patching process.

Good luck.

Screenshot for your reference:
Attachment:
vpatch.JPG
vpatch.JPG [ 171.73 KiB | Viewed 4695 times ]

_________________
+ORC: If you give a man a crack he'll be hungry again tomorrow, but if you teach him how to crack, he'll never be hungry again.
chumbucket: I don't collect pixels.

Never trust the client. It's in the hands of the enemy : UO Demo internals @ JoinUO


Top
 

 Post subject: Re: 64 Bit Windows: Installing the 5.0.8.3 Patch
PostPosted: Mon Aug 10, 2009 2:03 pm 
Offline
User avatar
User Rep: Trustworthy
Trustworthy
 WWW  ICQ  Profile

Joined: Thu Dec 13, 2007 7:49 pm
Posts: 9002
Location: Cove
Wow thanks Batlin; and to Varkalas for the report.
I've stickied this. We really need a better installer... :/

_________________
Image
"The text in this article or section may be incoherent or very hard to understand, and should be reworded if the intended meaning can be determined."


Top
 

 Post subject: Re: 64 Bit Windows: Installing the 5.0.8.3 Patch
PostPosted: Sun Nov 01, 2009 12:48 pm 
Offline
User Rep: Unsung
 Profile

Joined: Fri Oct 30, 2009 5:16 am
Posts: 13
i had trouble with vista 64 bit and this is how i got it to work

install uo into the public folder (user/public/(i used games)/uo)

then copy the patch file into that folder

now run the patch file

i also changed client.exe compatibility to xp sp2


Top
 

 Post subject: Re: 64 Bit Windows: Installing the 5.0.8.3 Patch
PostPosted: Sun Nov 01, 2009 2:34 pm 
Offline
User Rep: Unsung
 Profile

Joined: Tue Jun 16, 2009 11:09 am
Posts: 949
I could probably come up with a more compatible installer if i knew what files were being updated and such. I don't feel like figuring it out on my own ;p

_________________
Yew Bank Mall - UOAM v8.3/v9/UOSA Client Installer - UOSA @ SourceForge.net (Latest Versions Here) - Treasure Maps Offline


Top
 

 Post subject: Re: 64 Bit Windows: Installing the 5.0.8.3 Patch
PostPosted: Thu Nov 11, 2010 11:32 pm 
Offline
User Rep: Unsung
 Profile

Joined: Thu Nov 11, 2010 10:49 pm
Posts: 8
I ran the patcher as administrator and it worked fine for me. The first time I ran it without running it as administrator and it failed as your described.

Right click the patcher and select run as administrator then start it and see if it works for you.


Top
 

 Post subject: Re: 64 Bit Windows: Installing the 5.0.8.3 Patch
PostPosted: Fri Nov 12, 2010 5:35 am 
Offline
User Rep: Unsung
Post Rep: 1
 Profile

Joined: Tue Jun 16, 2009 11:09 am
Posts: 949
Come on guy.. this post is over a year old.

The new client installer includes everything needed and there are no patches to deal with.

_________________
Yew Bank Mall - UOAM v8.3/v9/UOSA Client Installer - UOSA @ SourceForge.net (Latest Versions Here) - Treasure Maps Offline


Top
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Support Second Age: These links Open in a New Window

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group  
Extended by Karma MOD © 2007—2012 m157y