All times are UTC - 5 hours [ DST ]


Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Ubuntu/Linux and Pulseaudio Issues
PostPosted: Sat Nov 07, 2009 4:09 pm 
Offline
UOSA Subscriber!
UOSA Subscriber!
User avatar
User Rep: Unsung
 Profile

Joined: Mon Aug 17, 2009 1:05 am
Posts: 230
I have a solution for the sound problem... After upgrading to Ubuntu 9.10, sound would be either choppy, or would work fine in UO for a few minutes until sound stopped working all together. Sometimes I could re-start the client to get sound back, other times not.

I tracked the problem down to the Pulseaudio sound server that the jerks at Ubuntu are forcing down our throats... In Ubuntu 9.04, you had the option to choose your sound server - Pulse, Alsa, OSS, etc.. They removed the option to choose.

PulseAudio has known issues with Wine, as wine wants to talk to the hardware. Alsa lets it, but when PulseAudio is in use, Alsa passes the audio over to Pulse before it makes it to the sound card.

So, there are two options: Try to use pasuspender, or remove PulseAudio all together.

pasuspender is a program that 'disables' pulseaudio for whatever application you specify on the command line... So you would want to go to properties on your icon for UO/Razor and add 'pulseaudio -- ' before the 'wine "C:\\Program Files...etc"' -- You may find that you have no sound, at which point you will need to install the aumix-gtk package and turn up the volume on "VOL" "PCM" and "PCM2"

I must note, that I didn't think to adjust volume levels using aumix before I did the next thing, which is to remove pulse all together... So the above may or may not work.

So, to remove PulseAudio from Ubuntu 9.10, do the following:

# Remove PulseAudio and reboot!
sudo killall pulseaudio
sudo apt-get purge pulseaudio
sudo reboot # or reboot through the Gnome dialogs

# Install asoundconf-gtk and aumix-gtk
sudo apt-get install aumix-gtk
sudo apt-get install asoundconf-gtk

# Download the missing 'asoundconf' binary, as it is no longer in the alsa-utils package!!!
Get alsa-utils_1.0.18-1ubuntu11_i386.deb from here (64-bit version also on the page):
http://packages.ubuntu.com/jaunty/alsa-utils

Extract asoundconf from alsa-utils*.deb with Archive Manager
Then put it in the proper place:
sudo cp asoundconf /usr/bin/

# Type on Terminal, or from your run dialog:
asoundconf-gtk

# Select your sound card from the list. Mine showed "LIVE", as I have a Sound Blaster Live! card.

# Run aumix-gtk, from the menu->Sound & Video->aumix
Make the window larger so you can see the sliders better. I had turn "PCM2" way up before I could hear anything.

I now have working sound on UO (and flash, and all the other apps I was having problems with), and my system seems to be more responsive. The only problem still, is the stupid Gnome volume control only works with Pulse!! But I would rather have working sound and no volume control applet, than an applet and crappy sound. I'll just run aumix until the volume control is fixed.

_________________
Image


Top
 
These Support SecondAge
Links open a new window.
UOSA Donors & Subscribers do not receive these ads.

 Post subject: Re: The....How to play UO on Linux Thread
PostPosted: Thu Feb 04, 2010 11:48 am 
Offline
UOSA Donor!!
UOSA Donor!!
User avatar
User Rep: Unsung
 WWW  ICQ  YIM  Profile

Joined: Wed Feb 04, 2009 9:11 am
Posts: 241
Location: NC
Concerning Pulseaudio, the easiest work around to try is to use the ALSA plugin for Pulseaudio. My Ubuntu 9.10 installation came with it already installed. However I donot use the ALSA plugin for anything.

I would not be so quick to dismiss Pulseaudio as being inadequate. My installation of UO under Ubuntu went flawlessly and my sound works perfect with all my games and applications. What is more likely to be the issue with Pulseaudio, is that it does not like some sound card chipsets... ALSA had the same issues with compatibility of some cards also. Googling the issue I see around the same number of problems with ALSA that I see with Pulseaudio only with different chipsets...

The extra steps required for a Sound Blaster Live, is a known issue, and the documentation that Hans has provided is probably the best written method i've seen and deserves a seperate sticky. Beware moderate knowledge in Linux would help to follow his document.

Why Pulseaudio works with a generic chipset better than a name brand, much better card is beyond me. Maybe Realtek's open source driver is better written then Creative Lab's?

My integrated sound card is a Realtek ALC888VC.
My motherboard's chipset is a North Bridge: Intel G41 Expresswith a South Bridge: Intel ICH7

_________________
Image


Top
 

 Post subject: Re: Ubuntu/Linux and Pulseaudio Issues
PostPosted: Wed Apr 14, 2010 8:04 pm 
Offline
User avatar
User Rep: Unsung
 Profile

Joined: Wed Apr 07, 2010 6:41 pm
Posts: 27
another thing about pulseaudio (at least if you have an AUDIGY SE) if you reboot and are dualbooting into windows, you will get no audio. Pulseaudio takes over and will not let go of your sound card.

A full shut down and start up in windows is required to get sound back.


Top
 

 Post subject: Re: Ubuntu/Linux and Pulseaudio Issues
PostPosted: Tue Jan 18, 2011 7:53 am 
Offline
User Rep: Unsung
 Profile

Joined: Tue Jan 18, 2011 7:50 am
Posts: 9
I had this issue and to resolve it I simply went to the wine configuration panel under Applications and changed the hardware acceleration to Emulation on the Audio tab.

The next time I logged in I was greeted by the sound of a loud cougar!


Top
 

 Post subject: Re: Ubuntu/Linux and Pulseaudio Issues
PostPosted: Tue Jan 18, 2011 12:00 pm 
Offline
UOSA Donor!!
UOSA Donor!!
User avatar
User Rep: Unsung
 WWW  ICQ  YIM  Profile

Joined: Wed Feb 04, 2009 9:11 am
Posts: 241
Location: NC
I had to do the exact same thing under Ubuntu 10.4 to get sound working with wine applications, specifically UO.

_________________
Image


Top
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Support Second Age: These links Open in a New Window

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group  
Extended by Karma MOD © 2007—2012 m157y