All times are UTC - 5 hours [ DST ]


Post new topic Reply to topic  [ 13 posts ] 
Author Message
 Post subject: Wine / dotnet / Razor issue
PostPosted: Tue Jul 06, 2010 6:18 pm 
Offline
User avatar
User Rep: Unsung
 Profile

Joined: Thu Apr 02, 2009 7:46 pm
Posts: 1400
Ok I thought it was just me but apparently there's a huge bug with the new wine / Razor / .NET installer. Basically WINE will NOT detect .NET when installing Razor. I'm going to do some more testing and come back with results. If anyone has a fix or is interested in working on one please post here.

EDIT: Thanks to cocainezombie for the solution.

cocainezombie wrote:
I found a solution. After installing dotnet2.0 winetrick Just unpack Razor installation file (Razor_Latest.exe) and run updater.exe. It should create needed registry files and razor will start. However, there is a bug when you don't see checkboxes in Razor.


Use the following method to accomplish this:

Code:
$ mkdir ~/.wine/drive_c/Program\ Files/Razor
$ mv Razor_Lastest.exe ~/.wine/drive_c/Program\ Files/Razor/Razor_Latest.exe
$ cd ~/.wine/drive_c/Program\ Files/Razor
$ 7z x Razor_Latest.exe

_________________
chumbucket wrote:
Everyone else, don't be a jerk to staff. Maahes cries enough already.


viewtopic.php?f=33&t=40810 - HOLY HELL AN AWESOME VENDOR?!


Top
 
These Support SecondAge
Links open a new window.
UOSA Donors & Subscribers do not receive these ads.

 Post subject: Re: Wine / dotnet / Razor issue
PostPosted: Sun Jul 11, 2010 12:23 am 
Offline
User avatar
User Rep: Unsung
 Profile

Joined: Tue Jul 06, 2010 2:54 am
Posts: 5
Found anything yet? I'm still having this issue unfortunately.


Top
 

 Post subject: Re: Wine / dotnet / Razor issue
PostPosted: Fri Jul 16, 2010 12:29 pm 
Offline
User Rep: Unsung
 Profile

Joined: Fri Jul 16, 2010 12:16 pm
Posts: 1
I found a solution. After installing dotnet2.0 winetrick Just unpack Razor installation file (Razor_Latest.exe) and run updater.exe. It should create needed registry files and razor will start. However, there is a bug when you don't see checkboxes in Razor.


Top
 

 Post subject: Re: Wine / dotnet / Razor issue
PostPosted: Mon Jul 26, 2010 4:07 pm 
Offline
User avatar
User Rep: Unsung
 Profile

Joined: Wed Sep 23, 2009 10:55 am
Posts: 8
Location: Pavia (Italy)
cocainezombie wrote:
I found a solution. After installing dotnet2.0 winetrick Just unpack Razor installation file (Razor_Latest.exe) and run updater.exe. It should create needed registry files and razor will start. However, there is a bug when you don't see checkboxes in Razor.



how can you extract Razor_Latest.exe? with cabextract didn't work :?


Top
 

 Post subject: Re: Wine / dotnet / Razor issue
PostPosted: Thu Jul 29, 2010 4:40 pm 
Offline
User avatar
User Rep: Unsung
 Profile

Joined: Thu Apr 02, 2009 7:46 pm
Posts: 1400
wallak wrote:
cocainezombie wrote:
I found a solution. After installing dotnet2.0 winetrick Just unpack Razor installation file (Razor_Latest.exe) and run updater.exe. It should create needed registry files and razor will start. However, there is a bug when you don't see checkboxes in Razor.



how can you extract Razor_Latest.exe? with cabextract didn't work :?


Code:
$ mkdir ~/.wine/drive_c/Program\ Files/Razor
$ mv Razor_Lastest.exe ~/.wine/drive_c/Program\ Files/Razor/Razor_Latest.exe
$ cd ~/.wine/drive_c/Program\ Files/Razor
$ 7z x Razor_Latest.exe

_________________
chumbucket wrote:
Everyone else, don't be a jerk to staff. Maahes cries enough already.


viewtopic.php?f=33&t=40810 - HOLY HELL AN AWESOME VENDOR?!


Top
 

 Post subject: Re: Wine / dotnet / Razor issue
PostPosted: Sun Aug 29, 2010 10:25 pm 
Offline
User avatar
User Rep: Unsung
 Profile

Joined: Wed Jan 21, 2009 12:10 am
Posts: 139
Ok, I'm grounded here. When running update.exe, I got a error:
'A application has made a attempt to load the C runtime library incorrectly'

Any ideas?

_________________
Slowly Lord British, ruler of Britannia, rises from his throne. Brushing the dust off of his crown, a concerned realization crosses his face. The rumors are true!


Top
 

 Post subject: Re: Wine / dotnet / Razor issue
PostPosted: Mon Aug 30, 2010 8:12 am 
Offline
User avatar
User Rep: Unsung
 Profile

Joined: Wed Jan 21, 2009 12:10 am
Posts: 139
Fixed, I did the trick!

I had to remove the .wine directory, and start from scratch.
First, install dotnet with winetricks, then razor, then UO.

Now everything is running fine.

_________________
Slowly Lord British, ruler of Britannia, rises from his throne. Brushing the dust off of his crown, a concerned realization crosses his face. The rumors are true!


Top
 

 Post subject: Re: Wine / dotnet / Razor issue
PostPosted: Mon Sep 13, 2010 10:05 pm 
Offline
User Rep: Unsung
 Profile

Joined: Mon Sep 13, 2010 1:18 pm
Posts: 9
please please please, can somone get in vent and talk me through this? anyone?
vent name is Shogun ..holla at me


Top
 

 Post subject: Re: Wine / dotnet / Razor issue
PostPosted: Tue Nov 30, 2010 7:09 am 
Offline
User Rep: Unsung
 Profile

Joined: Thu Nov 25, 2010 1:00 pm
Posts: 97
Any chance someone knows how to display razor checkboxes ?

_________________
Image
making your own forum avatar/banner using Adobe CS5. Cheap and Fast delivery, pm me for details.


Top
 

 Post subject: Re: Wine / dotnet / Razor issue
PostPosted: Tue Nov 30, 2010 7:17 am 
Offline
UOSA Donor!!
UOSA Donor!!
User Rep: Unsung
 Profile

Joined: Tue May 19, 2009 8:57 pm
Posts: 43
I found the fix. I installed Windows.


Top
 

 Post subject: Re: Wine / dotnet / Razor issue
PostPosted: Tue Nov 30, 2010 5:40 pm 
Offline
User Rep: Unsung
 Profile

Joined: Thu Nov 25, 2010 1:00 pm
Posts: 97
Without having to use a proper windows install I meant :)

_________________
Image
making your own forum avatar/banner using Adobe CS5. Cheap and Fast delivery, pm me for details.


Top
 

 Post subject: Re: Wine / dotnet / Razor issue
PostPosted: Sat Dec 11, 2010 3:07 pm 
Offline
User Rep: Unsung
 Profile

Joined: Thu Nov 25, 2010 1:00 pm
Posts: 97
ImaNewbie wrote:
Any chance someone knows how to display razor checkboxes ?



bump

_________________
Image
making your own forum avatar/banner using Adobe CS5. Cheap and Fast delivery, pm me for details.


Top
 

 Post subject: Re: Wine / dotnet / Razor issue
PostPosted: Fri Jul 18, 2014 7:28 pm 
Offline
UOSA Donor!!
UOSA Donor!!
User Rep: Unsung
 Profile

Joined: Sat Dec 13, 2008 8:27 pm
Posts: 4
I know, I know, this is pure threadecromancy but since this post is quite well indexed on google I think it's best to add a reply here regarding this issue than creating a new thread.

Quote:
"After wine 1.7.11 and later dotnet20 doesnt work..."
http://uorforum.com/threads/uor-wine-linux-mac-windows-xd-whatever.3417/ so you must run
Code:
$ bash winetricks dotnet20sp2
and Razor will finally work again.

I am using UOSA_Client_Setup.exe found on uosecondage.com since it's my favourite server.

Hopefully this will solve some problems... too bad, Razor will update automatically but if you want to keep the old version simply run it without an active internet connection and you're safe...

Cheers! (and choose wisely: Slackware Linux! http://www.slackware.com)


Top
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Support Second Age: These links Open in a New Window

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group  
Extended by Karma MOD © 2007—2012 m157y